QXPRESS VERSION 10.0 FEATURE LIST
This document lists the main new features included in the QXpress version
10.0 release. For each feature listed, where applicable, there is also a
description of the feature and step-by-step instructions explaining how to
use the feature.

QUICKBOOKS INTEGRATION
1. QuickBooks 2011 compatibility
Versions: All
QXpress 10.0 has been configured to be compatible with the upcoming
release of QuickBooks 2011 US, Canadian 2011, South African 2010 and
UK 2010, and Australian 2009/2010.

2. Inactive customers - ability to view and alter from QXpress
Versions: All
You can now view inactive QuickBooks customers in QXpress, as well as
set the active/inactive status of a QuickBooks customer. In previous
versions of QXpress only active customers were visible in QXpress and
altering the status had to be done in QuickBooks directly.
To view inactive customers:
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1)

Go to Lists > Customer List.

2)

Place a check in the Show Inactive checkbox.

3)

Look for customers that have an “X” icon in the first column.

4)

Double-click on the inactive customer to be taken to their account.
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To set active/inactive on a customer:

Note:

1)

View an active customer / inactive customer in the Customers screen.

2)

Click Edit Customer....

3)

Check or uncheck the Is Active? checkbox.

4)

Click OK.

The preference for showing active/inactive customers will be saved and retrieved for
each user of QXpress.

3. Marking QuickBooks transactions as ‘posted’ even though
they are not.
Versions: All
Under the Post to QuickBooks menu a list is displayed for all invoices,
service times, inventory adjustments and vendor bills that have not yet
been sent to QuickBooks. Since some users only start exporting these
transactions to QuickBooks at a later stage in their QXpress use, there is
often a large list of old transactions you may want to remove first, before
you start exporting transactions from this point forward. In previous
versions of QXpress, the only way to remove these from the list was to
make a backup of QuickBooks, post the transactions over, and then restore
the backup. Those days are gone! You can now mark transactions as
posted easily from QXpress.
To mark invoices as posted:
1)

Go to Post to QuickBooks > Invoices.

2)

Select all the invoices you want to mark as posted - or use SELECT ALL to
select all invoices.

3)

Right-click and choose Mark as Exported.

4)

Agree to the prompts. You’ll see the invoices now under the Already sent
to QB tab, with an export date of Jan-01-1980.

To mark service times as posted:
1)
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Go to Post to QuickBooks > Service Times.
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2)

Select all the services times you want to mark as posted - or use SELECT
ALL to select all service times.

3)

Right-click and choose Mark as Exported.

4)

Agree to the prompts. You’ll see the service times now under the Already
sent to QB tab, with an export date of Jan-01-1980.

To mark vendor bills as posted:
1)

Go to Post to QuickBooks > Vendor Bills.

2)

Select all the vendor bills you want to mark as posted - or use SELECT
ALL to select all vendor bills.

3)

Right-click and choose Mark as Exported.

4)

Agree to the prompts. You’ll see the vendor bills now under the Already
sent to QB tab, with an export date of Jan-01-1980.

To mark inventory adjustments as posted:
1)

Go to Post to QuickBooks > Inventory Adjustments.

2)

Select all the inventory adjustments you want to mark as posted - or use
SELECT ALL to select all inventory adjustments.

3)

Right-click and choose Mark as Exported.

4)

Agree to the prompts. The adjustments will disappear from the list.

4. Sales Rep added to Add/Edit Customer screen
Versions: All
QXpress now has the QuickBooks ‘Rep’ field added to the Add/Edit
Customer screen allowing you to view, add and edit the assigned rep to a
QuickBooks customer.
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SCHEDULING
5. Read-only permissions on the calendar / service screen
Versions: Platinum and Enterprise
You can now give permission to staff to view but not edit, add, move,
reschedule or otherwise make any change to a service in QXpress. This is
useful for field staff that need permission to see their work and print it off,
but not make modifications.
To use this feature:

Note:

1)

Go to Tools > Options.

2)

Go to the Login Permissions tab.

3)

Edit a user that you want to give read-only permissions to.

4)

Advance to step 33 of the wizard and set ‘no access”.

5)

Click Finish.

6)

Login as that user now and you’ll see that they have no ability to modify a
service from the service screen or from the calendar.

It is important to also play close attention to other areas of QXpress that need
permissions set for this user, as permissions on other screens may still allow them to
modify services.

6. Auto-Refresh of calendar
Versions: All
If the calendar is idle for a specified period, meaning there have been no
modifications to it, a background timer will automatically refresh the
calendar. This allows your staff to have the calendar refresh automatically
with the latest work orders without any interaction or interruption - this is
very useful in a network environment where many users are adding and
moving services on the same QXpress file. The calendar now also shows
the last time it was refreshed next to the Refresh button.
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To use this feature:
1)

Go to Tools > Options.

2)

Go to the Routing & Scheduling tab.

3)

Set the Auto calendar refresh dropdown list to either 5 minutes, 10
minutes, 15 minutes, 30 minutes, 60 minutes or never. By default this is 5
minutes. If you want to turn this feature off entirely, set the value to never.

To skip a pending refresh:
1)

If the autorefresh is approaching approximately 1 minute the last refreshed
label next to the Refresh button will turn red and start counting down the
seconds to refresh.

2)

If you want to skip this refresh, simply click the red label and the next
autorefresh will occur later.

To view the next scheduled auto-refresh:
1)

Hover your mouse over the last refreshed label and you’ll see the next
scheduled refresh time.

7. Ability to select and delete a group of services from the Customer screen.
Versions: All
Previously, to delete a service you needed to first edit the service, and click
Activities > Delete. This was made deliberately hard so that it would be
difficult to delete services by mistake. However, when deleting many
services, the process can be cumbersome. In QXpress you can now delete
a group of services directly from the Customer screen.
To use this feature:
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1)

Go to the Customer screen.

2)

Select a customer.

3)

Select the Schedule tab.

4)

Highlight the services you wish to delete.
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5)

Click Schedule > Selected Services / Billing Installments > Delete.

6)

Agree to the prompts.

8. Ability to set the renewal date for a group of services from the
Customer screen.
Versions: All
To use this feature:
1)

Go to the Customer screen.

2)

Select a customer.

3)

Select the Services tab.

4)

Highlight the services you wish to set the renewal date of.

5)

Click Schedule > Selected Services / Billing Installments > Change
renewal date.

6)

Enter the new renewal date, and click OK.

9. Printing work orders from the Recurring Dates tab
Versions: All
You can now print work orders from the Recurring Dates tab of the service
screen.
To use this feature:
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1)

Open the Service screen to series of the desired recurring service.

2)

Go to the Recurring Dates tab.

3)

Click on the service date of the work order you want to print. Ensure that
this service date has an On Route status.

4)

Click Activities > Print Work Order.
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10. Renewal Center: Ability to remove any line item, not just discounts
Versions: All
Previously the renewal center was limited to only resetting discount lines of
renewable services. Due to the requests of QXpress users, we have
changed Step 3 of the renewal center from “Reset discounts” to “Reset Job
Items and Discounts”, allowing you to remove any type of job item.
To use this feature:
1)

Go to Tools > Renewal Center.

2)

Go to step 3.

3)

Change the radio button from “Show only discount job items” to “Show all
job items”.

4)

Remove whichever job items you desire.

11. Renewal Center: Filter options on all grids
Versions: All
You will now see filter options on the top of all grids in the renewal center,
making it a lot easier to renew for certain customers or certain service
descriptions.
To use this feature:
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1)

Go to Tools > Renewal Center.

2)

Select any of the four tabs.

3)

Enter a partial match for your desired customer or service into the filter
textboxes at the top of the tab.

4)

Click Filter.
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MARKETING
12. Leads
Versions: Platinum and Enterprise
For the first time, it is now possible to have customers in QXpress that are
not automatically posted to QuickBooks. These customers are called
“Leads” and only get converted to customers when you are ready. This
means you can have hundreds or thousands of potential customers in
QXpress for marketing purposes, and not clutter up your QuickBooks file!
To add a new lead:
1)

Go to Lists > Customer List.

2)

Go to the List tab.

3)

Click New.

4)

In the Add QuickBooks Customer screen, place a check in the Lead - don’t
create in QuickBooks yet checkbox, and notice that the screen caption will
become Add Lead.

5)

Choose a Lead Source (optional). If you want to create or modify a new
Lead Source, click the “...” button next to Lead Source.

6)

Choose a Lead Status (optional).
Closed Lead Statuses (meaning you are finished trying to get them as a
customer) are:
“Won”, “Lost”, “Void”, “Sold Alternative”
Open Lead Statuses (meaning you are still trying to get them as a
customer) are:
“Open”, “New”, “Hold”
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7)

Enter a Lead Closed Date. Note, this date is automatically entered for you
if you choose a “closed” Lead Status.

8)

Fill out the customer information as you would for a regular QuickBooks
customer.

9)

Click OK.
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To view a lead in the customer list:
1)

Go to Lists > Customer List.

2)

Go to the List tab.

3)

Make sure the Show Leads checkbox has a check in it.

4)

Locate the lead in the list and double-click on their name. Notice that the
lead will have “Lead” in the Status column.

To convert a lead to a customer:
1)

View the lead in the Customers screen.

2)

Click Edit / Convert Lead....

3)

Uncheck the Lead - don’t create in QuickBooks yet? checkbox.

4)

Click OK.

To filter the customer screen by lead status/source/source class:
1)

In the Customers screen click the Find tab.

2)

Go to the Lead Information tab.

3)

Select a filter value for Lead Source, Lead Source Class, Lead Status.

4)

Click Filter.

To view / create reports for leads:
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1)

Go to Reports > Template Designer Reports.

2)

Click Download Template....

3)

For Shared Name filter by ‘Leads_Status’.

4)

Look for the reports ‘Leads_StatusByRepDetail’,
‘Leads_StatusByRepSummary’, ‘Leads_StatusBySourceDetail’,
‘Leads_StatusBySourceSummary’, or any other reports that are created
by QXpress Software.

5)

Select the desired report and click Download Selected Template.
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Note:

You’ll notice that the AID of a lead customer is a very high number until converted. All
leads are assigned an AID number from 1,000,000 and higher. Once they get
converted they will receive a proper AID from QuickBooks.

OTHER
13. Emailing PDF and dispatch emails using Outlook
Versions: All
You can now choose to email PDFs and dispatch to email/pager using
Outlook instead of the QXpress mail server. This allows you to see a
history of what has been sent, as well as more control over your own
environment.
To set this preference:

Note:

1)

Go to File > Emails forms. Click OK to any messages that come up with
the caption “No emails need sending”.

2)

Click Server Settings.

3)

Change the Email Server Settings to Use Outlook.

4)

Click OK.

You must be using the Report Designer 2.0.0.206 or higher to use this feature for
PDFs.

14. New customer billing address entry more closely follows
QuickBooks
Versions: All
When adding new customers, if the 2nd line of the billing address is empty
and the 1st line is the company name, then exiting the last name field will
put the name on the 2nd line. This matches better how QuickBooks does it.
Previously if the 1st line of the billing address was occupied it would not
enter the customer’s name in the billing address.
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In addition, using the up and down keyboard arrows in the bill to address
and ship to address now allow you to move up and down the text box,
emulating QuickBooks.

15. New permission - Edit custom field settings
Versions: Platinum and Enterprise.
On step 34 of the permissions wizard you now have the option of limiting
who can add, edit and remove custom fields from the Customer screen and
from the Service screen.

16. Mail server settings no longer needed
Versions: All
If you are emailing PDFs and/or using the dispatch to email/pager feature,
you no longer have to put your company mail server credentials into
QXpress in order to use the QXpress mail server.

17. Enterprise Backup
Versions: Enterprise
QX Enterprise users who have a registered copy of SQL Server Standard,
WorkGroup or Enterprise can now schedule automatic database backups.
This can be done by going to File > Setup automatic SQL Server
Backup.
Note:

SQL Server Agent must be running on the server, and requires SQL Server Standard,
Workgroup or Enterprise (rather than the SQL Server Express version supplied by
default with QXpress Enterprise). If you only have the basic SQL Server Express
edition that was supplied with QXpress Enterprise you will not be able to use this
feature until you upgrade your SQL Server edition - which may come at a
considerable expense.

18. Backup reminders
Versions: All
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You can now configure startup alerts to remind you to backup your
database. To set this reminder go to Tools > Options, and set the Backup
Database Reminder option under the General tab. By default this will be
every 5 days.

19. Launch QXpress Documents folder
Versions: All
Since QXpress 9.5 came out, new databases and documents are no longer
stored in Program Files\QXpress. Instead they are stored in the Windows
documents\Application Data\QXpress folder. This folder is often hard to
find, and differs in location from XP to Vista and Windows 7. To make it
easier to find the QXpress documents folder, in QXpress 10.0 you can now
click File > Launch QXpress Documents folder from the Login screen,
as well as Help > Launch QXpress Documents folder from inside
QXpress. This will open up the folder in Windows Explorer.
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