
QXPRESS VERSION 8.0 FEATURE LIST

This document lists the main new features included in the QXpress version 
8.0 release. For each feature listed, there is also a description of the 
feature and step-by-step instructions explaining how to use the feature.

QUICKBOOKS INTEGRATION

1. QuickBooks 2008 compatibility

Versions: All

QXpress 8.0 has been configured to be compatible with the upcoming 
release of QuickBooks 2008 US, and Australian 2007/2008. While QX8 is 
not currently compatible with Canadian and UK 2008, it will be by the time 
QX8 is released.

2. Changes-only sync

Versions: All

A new feature has been added to the QX Sync screen that allows you to 
only request the latest changes from QuickBooks, rather than a refresh of 
the entire QuickBooks database. This provides a significant benefit for 
larger companies since the processing time for a sync is very short, and 
does not require all users to log out of QXpress.

Note: Although this is a QX8 feature, it was made available at the tail end of the QX7 
product cycle

3. Performance increase on adding or modifying customers

Versions: All

Users that have large customer lists will see a significant performance 
increase when adding or modifying customers in either QXpress or 
QuickBooks.
Alocet Feature List 1



Note: Although this is a QX8 feature, it was made available at the tail end of the QX7 
product cycle.

4. Capitalization of states and postal codes

Versions: All

There is now an option to automatically capitalize state / province 
abbreviations as well as postal codes when adding or editing a QuickBooks 
customer.

To turn on this feature:

1) Click Edit > Preferences.

2) Under the General tab, check the "Automatically capitalize State and Zip 
Code?" checkbox.

Note: The capitalization will occur when you click or tab out of the field, not while you are 
typing.

5. Override on edit sequence

Versions: All

In previous versions if you add or edit a QuickBooks customer and 
someone else has added or edited the customer since you started, you 
would be refused the ability to save changes. This has been improved so 
that you will now get a prompt to see if you want to override the warning 
and send your changes anyway.

EQUIPMENT

6. Warranty information on equipment

Versions: Gold, Platinum and Enterprise
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There are now three additional fields available in the Equipment screen: 
"Expiry on labor", "Expiry on parts" and "Notes".

To enter information into these fields:

1) Click Lists > Equipment.

2) Double-click on an existing equipment, or click New to create a new one.

3) Enter warranty information into the Warranty frame.

7. Equipment on Job Items

Versions: Gold, Platinum and Enterprise

You can now specify equipment for servicing when scheduling a new 
service. This is especially useful for companies that maintain equipment on 
customer job sites, such as heaters, boilers and air conditioning units. By 
using the Job Items tab a user can list several different units of equipment 
to be serviced on a one time or recurring basis.

To turn on the feature:

1) Go to Edit > Preferences.

2) Click on the Routing & Scheduling tab.

3) Place a check in the "Show Equipment column in the Job Items tab?" 
checkbox.

To use this feature:

1) Open up any service.

2) Click on the Job Items tab.

3) Choose equipment from the Equipment column.

Note: You may have to stretch the Service screen to be wider to see all columns. The 
screen size will be remembered for next time.

Note: The template datasources for route lists and work orders haven't been updated yet to 
show equipment information. This will occur on the release of QX8.
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CONTACT MANAGER

8. Printing Contact Events

Versions: Gold, Platinum and Enterprise

Events can now be printed directly from the Add/Edit Contact Manager 
Event screen. Previously events could only be printed from the Contact 
Events list. 

9. Templates for Contact Events. 

Versions: Platinum and Enterprise

Contact Event reports can now be printed using either standard reports, or 
a Template Designer report, if a Platinum or Enterprise user.

Note: The latest "Contact_Manager_Events" template will need to be downloaded so that 
the latest ContactManagerEvents4 datasource can be used to create templates.

10. Alerts

Versions: Gold, Platinum and Enterprise

An "Alert" field has been added to contact events so that a screen appears 
when a new service is being scheduled for that customer. This is especially 
useful if you want to flag the customer as someone you no longer want to 
provide service to (such as a slow payer or a ‘difficult’ customer), or for 
more positive reasons such as reminding for upsells, or when customers 
have specific needs, you can make an event that will prompt you to ask 
about those needs.

To set and test an alert for a customer:

1) Click Lists > Contact Manager.

2) Choose an existing event and click Edit Event, or click New Event.
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3) Fill out the fields as necessary, making sure Customer, Type and Status 
are entered.

4) Place a check in the "Alert: This event is raised when a new service is 
scheduled for this customer?" checkbox.

5) Schedule a new service in My Calendar, making sure that the same 
customer is chosen. When you click OK you'll get an alert showing all the 
contact events for that customer that have an alert specified. 

11. Related services can now be opened from within a contact 
manager event

Versions: Gold, Platinum and Enterprise

If you assign a related service to a contact event, it can now be opened 
directly from the Add / Edit Contact Event screen by clicking on the [...] 
button.

SCHEDULING

12. Conflict checking

Versions: All

There is now the ability to check each scheduled service to see if it conflicts 
with any future appointments.

To turn this on:

1) Go to Edit > Preferences.

2) Click on the Routing & Scheduling tab.

3) Put a check in the "Show Scheduling Conflicts button in the Service 
screen?" checkbox.

4) Click OK.
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To use this feature:

1) Schedule a new service, or open an existing one.

2) Ensure that your service has a Start Time and Until Time filled out.

3) From the Service screen, click on the "Check For Conflicts" button, which 
can be found between the Quick Invoice button and the OK button.

Note: Appointments will not be considered conflicts if they are for the same customer. 

13. Appointment Colors

Versions: All

The ability to color-code appointment in Day View and Week View, has 
been added.

To use this feature:

1) Schedule a new service, or open an existing one.

2) Click on the General tab.

3) In the top right, change the "Appt. Color" dropdown list to the desired color.

4) Click OK.

5) Find the service in My Calendar under either the Day View or Week View.

Note: There is no way to change the label of the color. It is currently just the color's name.

Note: Appointment colors are not available for List View or Month View.

Note: There is no way to automatically set a default appointment color per crew.

Note: "Selected" appointments will always be assigned a blue color, regardless of what the 
appointment color is.

To set default appointment colors per Charge Description:

1) Click Lists > Charge Description List.

2) Click on an existing Charge Description.
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3) Click Advanced.

4) Click on the Advanced tab.

5) Make a selection from the "Default appt. color:" dropdown list.

6) Click OK.

Note: This will not affect existing appointments. 

14. Project Visit service times

Versions: Platinum and Enterprise

For project, when a project visit is turned On Route, a blank service time 
with the project visit's date is automatically inserted. This saves clutter on 
large projects by only inserting blank records as they are turned On Route. 

15. My Week

Versions: All

You can now define when your "week" begins and ends, rather than just 
have the default of Monday to Friday.

To edit this setting:

1) Click Edit > Preferences.

2) Click on the Day View tab.

3) Make the desired selection from the "My week:" dropdown list.

4) Make sure you have the "Week" view selected in My Calendar.

5) Click Refresh.

16. Charge Description field length

Versions: All
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The number of characters permitted for a Charge Description has 
increased from 50 characters to 250. 

17. A significant performance increase on the "Estimated Hours" 
field

Versions: All

This dramatically increases the performance of My Calendar and the 
Waiting List. As well, route list, work order and "All Scheduled Jobs" 
reports, when updated to the latest datasources, will have a significant 
performance increase. 

18. Dollar amounts in Month View

Versions: All

The ability now exists to hide sales and job cost revenue from the Month 
View calendar.

To set this feature:

1) Go to Edit > Preferences.

2) Click on the Day View tab.

3) Make the appropriate selection in the "Show dollar amounts in Month 
View?" checkbox.

19. Estimated hours column in List View

Versions: Gold, Platinum and Enterprise

The estimated hours column can now be made visible in the List View.

To set this feature:

1) Go to Edit > Preferences.

2) Click on the List View tab.
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3) Make the appropriate selection under the Est. Hours column.

20. Show totals in List View

Versions: All

The ability has been added to show totals of "Est. Hours" and "Amount" in 
the footer of the List View grid.

To set this feature:

1) Go to Edit > Preferences.

2) Click on the List View tab.

3) Make the appropriate selection for the "Show totals in footer?" checkbox. 

21. Waiting List sorting and position

Versions: All

In previous versions the Waiting List would lose its position and sorting 
when a job was either edited from the Waiting List or from the Calendar.  In 
QX8 it will remember this position.

22. Updating instructions from series to occurrence

Versions: All

A common new user question has always been why editing the instructions 
on the occurrence of a recurring service does not affect the instructions of 
the entire series. This happens because as soon as a service is turned On 
Route it is considered to be separate from all future dates so that you can 
have specific pricing or instructions for that one visit. To make this easier, 
however, you will now be prompted to see if you want to update the series 
when you make changes to the occurrence, and vise versa.

To turn this feature on or off:

1) Go to Edit > Preferences.
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2) Click on the Routing and Scheduling tab.

3) Make the appropriate selection for the "Prompt to update instructions on 
recurring series when updated in occurrence?" checkbox. 

23. Calendars for rescheduling

Versions: All

When you click Activities > Reschedule in My Calendar you will now be 
greeted with a calendar to choose the new reschedule date, rather than 
having to type in the new date manually.

OTHER

24. Create blank database

Versions: All

A new option has been added so that a new database can be created from 
the login form. Unlike the File > New Company Database option, this 
database is completely blank and does not include custom fields or 
templates from other databases.

To use this feature:

1) Go to the Login Form, by clicking File > Logoff / Login.

2) Click File > Create blank database (non-QX Enterprise).

25. Date change prompt

Versions: All

QXpress has been changed so that it won't stop to prompt to confirm that 
you want to change to the current date when the clock passes over 
midnight. It will just assume the clock should change.
10 Feature List Alocet



26. SQL 2005 compatibility

Versions: Enterprise

QXpress Enterprise is now compatible with SQL 2005. Previously only 
SQL 2000 was used.

Note: Although this is a QX8 feature, it was made available at the tail end of the QX7 
product cycle.

27. Post To QuickBooks reminders in Home screen

Versions: All

You now have the ability to show or hide the reminders to post invoices, 
service times, vendor bills and inventory adjustments to QuickBooks.

To set this feature:

1) Click Edit > Preferences.

2) Click on the Display tab.

3) Set the desired selection for each of the "Warn about unposted..." 
checkboxes.
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