
QXPRESS VERSION 9.0 FEATURE LIST

This document lists the main new features included in the QXpress version 
9.0 release. For each feature listed, where applicable, there is also a 
description of the feature and step-by-step instructions explaining how to 
use the feature.

QUICKBOOKS INTEGRATION

1. QuickBooks 2009 compatibility

Versions: All

QXpress 9.0 has been configured to be compatible with the upcoming 
release of QuickBooks 2009 US, Canadian 2009, South African 2009 and 
UK 2009, and Australian 2008/2009.

SCHEDULING

2. Copy Project Visits

Versions: Platinum and Enterprise

There is now a way to copy a project visit over a specified date range, 
making it very easy to schedule a project with a long duration.

To use this feature:

1) Schedule a new project, or open an existing one.

2) Go to the Project Scheduling tab.

3) Right-click on an existing project visit, and choose Copy Visit....

4) Choose a From date and a To date to copy the services within.
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5) Uncheck any days of the week that you would like excluded, such as 
Saturday and Sunday.

6) Click OK. You will now see the original project visit, along with the 
instructions and material load lists have been copied to each date in the 
date range.

3. Project Scheduling row resizing

Versions: Platinum and Enterprise

In previous versions of QXpress you could resize the row of the calendar 
inside the Project Scheduling tab, however, the row height would not be 
saved, causing you to have to resize it over and over again. In QX9 the row 
height is saved, and maintained on a per-user basis, so that each time you 
open QXpress the row height is the same size as it was last time you 
closed it.

4. Project Scheduling column resizing

Versions: Platinum and Enterprise

The Project Scheduling tab now allows you to stretch and resize column 
widths, so you can have a horizontal scroll through dates of a long project, 
and be able to see the contents of each visit.

INVOICING

5. To Be Emailed set in QuickBooks

Versions: Gold, Platinum and Enterprise

Invoices with the invoice type “Type 4”, “Type 5”, “Type 6” and not emailed 
directly from QXpress, will now be marked as “To Be Emailed” in 
QuickBooks.

Note: This features is only available in US Version 2007 and higher, and Canadian / UK / 
South Africa / Australia 2008 and higher.
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6. Invoice Type in Invoice List

Versions: All

There is now an Invoice Type column in the Invoice list, indicating what type of 
invoice setting the services on the invoice had before the invoice was created. 
This is especially helpful in determining which invoices need to be emailed, 
since the invoice type turns yellow once it has been sent for emailing.

7. ‘Copy Work Order # to Invoice #’

Versions: Gold, Platinum and Enterprise

There is now a ‘Copy Work Order # to Invoice # custom field on One Time 
and Project services’ preference that causes the default invoice number to 
be overwritten by the Work Order number of One Time and Project 
services when they are invoiced.

To use this feature:

1) Go to Tools > Options.

2) Click on the Routing & Scheduling tab.

3) Place a check beside the ‘Copy Work Order # to Invoice # custom field 
on One Time and Project services?’ checkbox.

4) Schedule a new project or a new one time service.

5) Go to the Custom Fields tab. You’ll see the Work Order # has been copied 
to your custom field named “Invoice #”. If you don’t have a custom field 
named “Invoice #”, you’ll need to make sure one of your 4 custom text 
fields on the service has this name, otherwise this feature is unavailable.

6) Invoice this service, and post the invoice to QuickBooks. You will see the 
Work Order # has been used as the Invoice #.

8. ‘Post As’ column in Invoice List, Accept Reject

Versions: All
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There is now a ‘Post As’ column in the Invoice List and Accept / Reject screen. 
Used together with the new ‘Copy Work Order # to Invoice # custom field on 
One Time and Project services?’ you can see what the true QXpress invoice 
number is, side-by-side with what the invoice number will be when posted to 
QuickBooks.

9. Accept Reject resizable

Versions: All

The Accept / Reject screen is now resizable. Although, seemingly a small 
feature, it was requested numerous times in the Suggestion Box.

MARKETING

10. Create Email List

Versions: Platinum and Enterprise

This is the *biggest* feature of QX9. Emailing through Microsoft Outlook is 
now integrated through QXpress so that you can do advanced emails 
directly to your customers from QXpress.

Creating an email marketing campaign can be done from Tools > 
Marketing > Create Email List.

Sending a customer an email directly from their account can be done by 
clicking Customer > Send Email.... 

Sending emails to a group of customers from the calendar can be done by 
selecting multiple services, and clicking Activities > Send Email.... 

Sending email correspondence related to invoices from the Invoice List can 
be done by selecting a group of invoices, right-clicking on the Print button, 
selecting Send Email.... 

Sending email correspondence related to a list of estimates or other work 
orders in the Customer Services List can be done by selecting a group of 
services, and clicking on Send Email.... 
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To use this feature:

1) Click Tools > Marketing > Send Email List.

2) Give your template a name under “Save template below as” so that your 
settings can be reused.

3) Under the Send emails to who? section, select who will receive your 
emails.

4) Enter a Subject.

5) Start typing your email in the Body.

6) Use the Insert Merge Fields for personalized information you would like 
QXpress to replace with customer information. For example, instead of 
writing “Dear Bob Crenshaw”, write “Dear ,” and insert BillToFullName in 
between, so that your email starts with “Dear (BillToFullName),”. As 
QXpress loops through all customers it will replace (BillToFullName) with 
the actual name of the current customer.

7) If you would like a more professionally formatted email, try typing out your 
email first in Microsoft Word. When you are happy with the appearance, 
save the Word document as an “.html” file, and use the Import Body 
feature of the Create Email List screen.

11. Export to Excel

Versions: Platinum and Enterprise

There are already two ways of exporting data to Excel (Mail Merge, and 
exporting a report). This as a 3rd option, that is a quick way of exporting 
any data available to reports, into Excel.

To use this feature:

1) Click Tools > Marketing > Export List To Excel.

2) Choose a Report Datasource. If the datasource you are looking for does 
not exist, try going to Reports > Template Designer reports and 
download a report that contains the data you need.

3) Choose a Memorized Filter List. This is optional. If the datasource contains 
customer information it will filter the list by the customers found within the 
Memorized Filter List.
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4) Under Save As File, give your file a name, like “C:\myfile.xls”.

5) Click OK. This may take a while to complete, depending on how big your 
list is. When it is done, it will open the exported list into Excel.

12. Custom Field Updater

Versions: Platinum and Enterprise

The custom field updater gives you a way of “flagging” a group of 
customers. It makes up for any shortcomings of what Memorized Filter 
Lists cannot do, such as look for customers who have empty values in 
certain fields, as well as combine the results of two distinct Memorized 
Filter Lists.

Example 1: What if you wanted to target anyone who had "Aeration" OR 
"Aeration & Rolling" by creating a Memorized Filter List. There is no OR 
(";") in Job Information! It gets complicated….what you need to do is create 
an intermediate step that puts "Aeration" into a custom field if they get 
either Aeration or Aeration and Rolling, and then build a Memorized Filter 
List using that custom field instead.

Example 1:

1) Make a Memorized Filter List, excluding every customer who got Aeration, 
and excluding everyone with Aeration & Rolling.

2) Go to Tools > Marketing > Custom Field Updater and use the “All 
customers NOT in a Memorized Filter List” option to put an “Aeration” flag 
in everyone who isn’t in your list (these are the customers you want!).

3) Build a new Memorized Filter List for all customers who have “Aeration” in 
the custom field.

Example 2: What if you wanted to find everyone who doesn't have a "zone" 
filled out. You can’t do a Memorized Filter List that looks for empty values. 
Use the Custom Field Updater to look for empty values and enter a flag into 
a custom field.
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QX Mapping

13. MASH-UP

Versions: All

There is a great new option in QX9 for QX Mapping users called “MASH-
UP”. It allows you to create a map in Microsoft MapPoint directly, draw 
territories and zones, save the map, and then use that map as the base for 
QX Mapping. That way all job site locations will be plotted onto the base 
map.

To use this feature:

1) Open MapPoint directly, and zoom into your area.

2) Using the “Draw” tools found in Microsoft MapPoint, draw shapes 
representing areas or zones. 

3) You will want to right-click on your shapes, choose Order > Send Behind 
Roads.

4) You may wish to tag your zones by dragging a symbol over top of a drawn 
area, and name it. You will want to right click, and choose “Show Name”.

5) Repeat for all areas / zones.

6) Save the map in a shared drive (eg. C:\QX Shared, or your database 
folder). Microsoft will assign a .ptm extension to the saved map.

7) In QXpress, go to File > QX Mapping > Open Existing Map. 

8) Choose your saved map.

9) Click Settings, and under Mash Up maps browse for your map in each 
situation you would like to apply your MASH-UP Map.
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Template Designer

14. Sub Report filtering

Versions: All

A long awaited and heavily requested feature is for the ability to apply 
filters to Sub Reports. This is especially useful on renewal letters that show 
all services, and previously gave no ability to limit what showed up in the 
Sub Report.

To use this feature:

1) Edit a report that has a Sub Report.

2) Right-click on the Sub Report you would like to filter on, and click Go To 
Sub Report.

3) Right-click on the Sub Report and look under Insert Fields On Sub Report 
to take note of the available fields you can filter on, and the exact spelling 
of those fields.

4) Right-click on the Sub Report and choose Properties.

5) Click on the Data Source tab.

6) As per the Examples on the screen, to filter on a single text field, and 
single text value, use a FieldName = ‘FieldValue’ format, for example: 
JobDescription = ‘Service Call’ 

7) To filter on a single text field, and multiple text values, use a FieldName IN 
(‘FieldValue1’,’FieldValue2’....’FieldValue100’) format, for example: 
JobDescription IN (‘Service Call’,’Installation’) 

8) To filter on a numeric field, and single value, use a FieldName = 123 
format, for example: JobRate = 100 

9) To filter on a single numeric field, and multiple values, use a FieldName IN 
(FieldValue1,FieldValue2....FieldValue100) format, for example: JobRate 
IN (1,2,3) 

10) To filter on a date field, using QX Standard, Gold and Platinum use a 
FieldName = #YYYYMMDD# format, for example: JobDate >= 
#20081225#.
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11) To filter on a date field, using QX Enterprise use a FieldName = 
‘YYYYMMDD’ format, for example: JobDate >= ‘20081225’.

OTHER

15. Support for currency symbol for South African Rand "R"

Versions: All

South African users, using the base UK version of QuickBooks will find that 
QXpress will now pickup the South African Rand symbol “R” and apply that 
throughout QXpress.

16. Calendar saves row height, per user

Versions: All

If you save the row height of the calendar in Day View, QXpress now 
memorizes this preference, on a per user basis, and re-applies the row 
height automatically next time you open QXpress.

17. Charge Description filter focus

Versions: All

When you open the Charge Description list the keyboard cursor will now 
take focus directly in the Charge Description Filter box. 

18. LastJobKindDate in Waiting List

Versions: All

The Last Job Kind Date column has been added as an optional field in the 
Waiting List.
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19. Mass replace Start and Stop Scheduling Dates in Advanced 
Charge Descriptions

Versions: All

The “...” mass update option has been added for Start Scheduling Date and 
Stop Scheduling Date from the Advanced Charge Descriptions screen.
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